My Adventures on Asteroid 5251, Part 5

2012-03-12 by . 0 comments

Post to Twitter

Last time, I was contemplating whether the monster filled meteorites had anything to do with why this planet’s abandoned…

Anyway, enough of that. Back underground! I run across my bridge, shocked when a creeper lands in front me and dies. Once I reach the glass dome, I tend the farm I started there last time, dig out some of the floor, and make some armor with it. I think I’m substantially more prepared this time.

Eh? Eh?

I get back on the rails and much to my horror, I discover that I accidentally loaded the version without the Enderman mod, so two of them had done their dirty work on my poor railroad. I exit Minecraft and reload the correct one. Fortunately, they only picked up the block under it and not the actual rail, so I am able to repair the track. When I look up again though, my cart is nowhere to be found and I still have the most dangerous stretch ahead. I have never been more thankful for the ability to sprint. :P Sure enough, my cart was waiting for me at the end. I continue on, and this time I find the room in the ‘shroom.

Continuing to the surface, I find a somewhat surprising site:

It looks so serene during the day.

It’s getting night, so I need to find that tunnel and fast lest this life be a repeat of the last. I eventually do find what I think is the right tunnel. I’m substantially more lavish with my torches as I bob through ultra-creepy terrain that makes me wish I had a boat.

With underwater chasms like that, I was expecting sharks at any moment.

I come out inside the weirdest thing I’ve ever seen in Minecraft…

I run and I run and I run but there’s just too many of them, much like Ronan’s run through the forest in part one of our “Race For Wool” “Game On!” So I wall myself into a corner. I eat some food, let my health regenerate, check on the status of my armor (still good), and wonder what next. I haven’t seen any other signs of people, this “forest” just keeps going. I have about 5 spiders and a skeleton outside my 2x2x1 enclosure, so I decide to remove one block and whack at them from there. I run out again and am forced to wall myself back up. I’m stumped.

Filed under Game Diaries

Subscribe to comments with RSS.

Comments have been closed for this post